pkgmake

pkgmake is a simple utility for making Solaris SVR4 packages.

It takes a directory structure containing the files you want to include in the package and produces a Solaris SVR4 package from it, resulting in a .pkg file suitable for distribution and installation.

The usually tedious process of creating a package is reduced to something like...

make DESTDIR=installtemp install
cp pkginfo installtemp
pkgmake installtemp
rm -rf installtemp

See the manual page for detailed usage instructions and examples.

Downloads

pkgmake-1.8-solaris-all.pkg.bz2
Solaris package, 6 Dec 2018, 18 KB
pkgmake-1.8.tar.bz2
Source code (shell), 6 Dec 2018, 20 KB

Installation

If upgrading from an earlier version, remove the old one first...

pfexec pkgrm LIGHTpkgmake

Then download the above package file, decompress, and install...

bunzip2 pkgmake-1.8-solaris-all.pkg.bz2
pfexec pkgadd -d pkgmake-1.8-solaris-all.pkg

The script and manual page are installed in /usr/local/bin and /usr/local/share/man/man1, as you would expect. Enjoy! ;-)

Technical Support

For support, please use the tech-support feedback form...

REGARDING IPS PACKAGES: Solaris 11 introduced a new package system called IPS which solves many shortcomings of the old SVR4 package system. Unfortunately, the new IPS package system requires software vendors to provide their Solaris software packages via special IPS repository server software. Packages are no longer stored as single "packaged" files, and they can't simply be downloaded from a normal web site. Unbelievable, I know, but true.

Even worse, the special IPS repository server software (pkg.depotd) only runs on Solaris. Since 95% of software vendors run their web sites on Linux or Microsoft Windows, this means installing and maintaining a separate server (real or virtual) just for Solaris software packages, which is very inconvenient and enormous overkill for such a small, niche use. It's also costly, as Oracle charges a substantial amount for access to Solaris security updates – a minimum of $1000 per year! Using the new Solaris 11 IPS package system is simply not viable when distributing free, open-source software that provides no income to offset such costs and hassles.

Fortunately, good old Solaris SVR4 packages still work fine on Solaris 11.

In the future, if Oracle provides a means of running an IPS repository on Linux, or even better, allows simple file access over HTTP/HTTPS to work as an IPS repository without special server software (as it should!), I will happily add support for generating IPS packages to this script.

Open Source

Copyright © 2003-2018 Lighterra – Open Source (MPL & LGPL). Details...

THIS IS OPEN SOURCE CODE DUAL-LICENSED UNDER THE MPL AND THE LGPL.

The basic intent is that:

  1. You may combine either open or closed source code with this code, and the result may be sold commercially if you wish.
  2. If you make any changes or additions to this source code you must publish them, typically by sending them back to the original author or project to be integrated into the main public distribution.
  3. You must acknowledge that your software uses this code by displaying a suitable notice somewhere, typically in an "about" dialog box, command-line version flag output, manual or other documentation.

If you are unsure whether this licensing fits your particular situation, please contact the author or copyright holder for clarification.

DUAL-LICENSING DETAILS

This software is subject to the terms of the Mozilla Public License Version 2.0 (the "MPL"). You may obtain a copy of the MPL from www.mozilla.org/MPL. Alternatively, this software may be used under the terms of the GNU Lesser General Public License Version 2.1 (the "LGPL"), in which case the provisions of the LGPL are applicable instead of those of the MPL. You may obtain a copy of the LGPL from www.gnu.org/licenses. If you wish to allow use of your version of this software only under the terms of the LGPL, and not to allow others to use your version of this software under the MPL, indicate your decision by deleting the provisions above and replacing them with the notice and other provisions required by the LGPL. If you do not delete the provisions above, a recipient may use your version of this software under either the MPL or the LGPL.

NO WARRANTY

This software is distributed in the hope that it will be useful, however software distributed under either the MPL or the LGPL is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either expressed or implied; without even the implied warranty of MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. See the MPL and the LGPL for details.